Board index General Technical Support MAF.i.a Dials port mafia on 2001 twin turbo lightning.

Dials port mafia on 2001 twin turbo lightning.

MAF.i.a Support

Moderator: mikel


Posts: 2
I have a 7324 mafia on my lightning running about 1200rwhp. The truck ran fine for a couple years now. I took it out and raced it and all was good. Took it back home and it sat for a few days. I then took it out for a little drive and it breaks up anytime I get over 10lbs of boost. It's set to number 3 with a ford GT maf. Data log says I am pegging the maf. I have checked and changed cop, flowed the injectors, spark plugs, battery, alternator etc. runs fine up to the 10lb of boost then just breaks up. Do these just go bad?


Posts: 52349
Location: DiabloSport World Headquarters

it sounds like its could have gone bad, can you see if MAF voltage changes if you move it to a different setting?
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 2
I have not switched the settings on it and tried to keep it running. I have way too much money wrapped up in this thing. Last time I tried switching the setting to two, it ran for a few seconds and died.


Posts: 52349
Location: DiabloSport World Headquarters

thats the plan, to see if switching it changes anything, might be best to get it to a good shop.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to MAF.i.a