Board index General Technical Support MAF.i.a Run's great with Mafia out of system...help needed?

Run's great with Mafia out of system...help needed?

MAF.i.a Support

Moderator: mikel


Posts: 4
2000 Ford Lightning;
Was added while being Dyno-tuned and was fine for 2k (about 1 1/2 yr) and then started to run all at once --- like a limp home mode.

I un-plugged the Mafia out of the system and truck runs fine, plug it back in and it runs bad.

Do these devices have a life end cycle??

Post Sun Apr 11, 2010 9:45 am

Posts: 4
Has anyone had to replace there Mafia unit ??

Post Mon Apr 12, 2010 11:20 am

Posts: 53704
Location: DiabloSport World Headquarters

If it is less than 2 years old, fill out an rma request and sens it in with a copy of the receipt.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Tue Apr 13, 2010 4:50 pm

Posts: 4
That's a great warranty and wish I knew this at the time, BUT Tony (at HP) sold it to me on 3/17/08.

How ever, I first experienced the MAFia issue in Dec 09.

So, I guess at this point --- I don't have a leg to stand on.

Regards

Post Tue Apr 13, 2010 5:00 pm

Posts: 53704
Location: DiabloSport World Headquarters

we can still fix it likely, just not under warranty...
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Tue Apr 13, 2010 5:41 pm

Posts: 4
Mike;
I'd like to have it fixed and would interested to know what I might have done wrong as I treat it (my Lightning) like my first born and only drive it once or twice a week.

How do I get permission to return it for repair ??


Return to MAF.i.a