Board index General Technical Support MAF.i.a Need to order products?

Need to order products?

MAF.i.a Support

Moderator: mikel

Post Fri Jan 19, 2018 9:07 am

Posts: 53925
Location: DiabloSport World Headquarters

Please feel free to give us a call, and our sales team will gladly assist you.

Whether you need a tuner, or accessories, or just have a question abut our tuning products, 561-908-0040x5 will get you what you need :)

Don't forget we have exhaust kits and Cold Air Intakes for many popular applications as well!



Thanks
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 5
Mike,

I have a Predator tuner with my Ripp Supercharger which has been installed on my 2010 JKUR for a few years. I love the setup.

However, yesterday I took my JK to the dealership for a passenger-side airbag recall issue. They didn't think to ask if I had a SC and I didn't think to tell them (hindsight....). Next thing you know they've re-flashed my ECM (using the right terminology?) and now the Predator won't recognize my vehicle. I cannot drive my everyday driver until the tune is back because of potential damage to the engine and/or SC.

I spent a combined 90 minutes on the phone with two different Diablo reps today... while at the dealership for five hours. My jeep is still at the dealership (I live 35 miles away!) and it seems nobody can figure out how to fix this.

My case number is 349248. Please help me out, you guys have my number.


Posts: 5
RubiNoVa wrote:
Mike,

I have a Predator tuner with my Ripp Supercharger which has been installed on my 2010 JKUR for a few years. I love the setup.

However, yesterday I took my JK to the dealership for a passenger-side airbag recall issue. They didn't think to ask if I had a SC and I didn't think to tell them (hindsight....). Next thing you know they've re-flashed my ECM (using the right terminology?) and now the Predator won't recognize my vehicle. I cannot drive my everyday driver until the tune is back because of potential damage to the engine and/or SC.

I spent a combined 90 minutes on the phone with two different Diablo reps today... while at the dealership for five hours. My jeep is still at the dealership (I live 35 miles away!) and it seems nobody can figure out how to fix this.

My case number is 349248. Please help me out, you guys have my number.


For any of you that read these posts I'd like to close the loop on this issue. Problems resolved thanks to the support I got at Diablo and Ripp. Thanks guys!

The longer story is, it wasn't easy. I wasn't able to use my Mac to upload the Ripp Supercharger tune onto the Diablo I3. I had to use the Jeep dealership's IBM (Windows) computer to upload the program. That was a pain but it got the job done. I then uploaded the Ripp tune and was able to drive the Jeep home. The Jeep ran as well, but not better, than it did on my Predator tune (I didn't expect much difference, if any).

Once home I tried to adjust the 91 Octane tune down to the lower octane using the Easy Tune feature. While I was at that I put in my tire size according to the sidewall and took off the speed limiter. That's when things went wrong! The speedometer was way off (it read 20 mph when I was actually going 45 mph... according to GPS), the engine light was on, a few other lights were on and the engine would rev up then down, up then down....

I tried to re-calibrate the speedometer several times and it didn't work. I tried to change the Octane tune, tire size, etc. back to normal but that didn't work. I finally called Ken at Diablo and we reset the tune back to stock, then installed the Ripp tune. Now all the lights on the dash were off except for the TPMS light. We measured the tire from road to top of the tire (34") and adjusted the tire size in Easy tune. Now, it appears, the speedometer is working properly. Time will tell the tale!

So, all's well that ends well. Thanks Ken for the patience and great support!

Post Sat Nov 17, 2018 8:36 am

Posts: 3
RubiNoVa:
Based on your user name, I assume you are in NoVA like I am. I had a similar experience at a "local" Jeep dealership (who shall remain unnamed but located in Leesburg). They flashed the PCM in my supercharged 2010 JK during an airbag recall and couldn't re-tune it. After 10 days of trying they said it was my fault for not disclosing the SC and, not able to resolve the issue (and refusing to call Diablo Sport), simply towed my Jeep to my house and left it there. I'm now working with Diablo's superb tech support people myself to get it revolved.


Return to MAF.i.a