Board index (Legacy) Predator Technical Discussion Predator GM Gas Will not complete firmware update *SOLVED*

Will not complete firmware update *SOLVED*

Predator support for GM gas vehicles

Moderators: mikel, 06MonteSS

Posts: 32
(Still here.... )

I found an old thread where a guy had a similar partial load problem when trying to transfer tunes to his PC. He was using a serial to serial cable. He used a different type of cable that his PC also had, and that worked.

I've ordered a serial to serial cable to try on my old PC that is still running XP. At the same time, I am upgrading my laptop to Win 10.

Ring any bells? Does that dredge up any recollection of similar problems that were solved?
Last edited by Reserector on Tue Oct 11, 2016 11:22 pm, edited 1 time in total.

Posts: 32
I fixed it.

I ordered a serial to serial cable and connected the tool to my old PC that is still running Windows XP. It loaded the crom on the first try with that setup.

I still have no idea why it wouldn't work with the USB to Serial cable. Tried two different computers, two different cables, and two versions of the drivers.

I suppose there's no school like old school. Hopefully this will help the next person who has this problem. Just try different hardware.

As a footnote, the eBay seller was genuinely concerned, and gave some great suggestions of things to try. Such a cool guy. Glad I bought from him.

Posts: 32
Wow. I went looking for the instruction manual and found information that would have helped me with this problem. ... ection.pdf

Why didn't someone point me to this stuff? It was under Support/ Technical Support/ Instructions and Manuals. I've spent hours on this problem. My son spent hours on hold. :blowup:

Posts: 32
One more thought; I use Panda Antivirus software. While trying to install DSlogredux, I found that the virus software was seeing the program as a threat, and deleting it. I went through my settings to white list it, and while I was at it, I told it not to scan USB devices.

Something like that could have been the reason why it would not fully load on my PC or my son's. He runs the same software.

The other case of the guy who solved his problem by using a different type of input cable may have had the same problem; virus scan software interfering with the USB-connected device.

I am not brave enough to try to reproduce the problem to prove my theory. But if someone out there is having this problem, please try changing your settings, or temporarily disable your antivirus software, and let me know if that fixes it.

Posts: 32
One more possibility: While updating my Garmin GPS, I found that it would not finish downloading, much like the Diablosport tool. I used a different Updater and got farther, but it told me that it lost communication with the device.
Long story short, the computer was shutting off the USB port to save power.

To disable, go into Device manager, and scroll down to Universal Serial Bus Controller. Then scroll down to USB Root Hub. (You may have several) Right-click on the first one and select Properties. Nest, select the Power Management tab. Uncheck the box that says Allow USB port to be turned off to save power (or something to that effect)
Do this to any or all ports that you want to remain ON.

This would explain why I was able to update with an RS232 cord; the computer was not able to turn off the RS232 port.


Return to Predator GM Gas