Board index (Legacy) Predator Technical Discussion Predator Dodge Gas u7136 v6 calibration update issue

u7136 v6 calibration update issue

Predator support for Dodge gas vehicles

Moderator: mikel

Post Mon May 30, 2011 1:11 pm

Posts: 117
I put a u7136 into a v6 charger on saturday, did the cal update, proceeded to instal the high octane tune.. started it up, not check engine light, ran good... sent the customer on his way... he comes back saying its "reving too high" so i test drive it, its staying in second gear, and starting in second as well... so i try another the lower octane tune, same thing... then i reset the tool back to stock, and the vehicle is doing the same thing... im assuming that the cal update wasnt a good one, and judging by the fact that the car is fine after it was re-flashed at the dealer, it seems to be the what i suspect... any ideas what happened? or if there is another cal file it may need? ... im concerned that if i try it again, im going to be stuck eatin another dealer bill for re-flash...

Post Tue May 31, 2011 2:45 pm

Posts: 6
I had a similar issue with the 89 and 91 octane tunes. Excessive cold start high idle and when warmed up, an idle that would keep me going about 35 mph on level ground. Fortunately returning to the stock tune was without problem. Hoping to see some solution here soon...

Post Tue May 31, 2011 2:51 pm

Posts: 55446
Location: DiabloSport World Headquarters

what revision is on the Predator?
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Sun Jun 05, 2011 7:34 pm

Posts: 6
Part: U7136
Ver: v.9r07
HW: UNIV_REV2

Post Mon Jun 06, 2011 1:05 pm

Posts: 55446
Location: DiabloSport World Headquarters

can you post the last tune written?
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Mon Dec 02, 2019 8:00 am

Posts: 1
Has there been a solution to this problem? Seems to be (almost) the same issue I am experiencing in 2019.

My 3.5 running on the 91 tune (U7196, 9r07, 04896411AL CalID) has a very high idle of 2500RPM on cold (30's F) starts. This although settles after +/- 2 seconds to a more resonable 1500RPM. 2800RPM still seems very high for a stone cold engine to start with though.

When driving in overrun the car doesn't seems to be slowing down much when removing the gas. It keeps chugging allow, as if the cruise control is on. The RPM's don't really come down until the vehicle is completely stopped.

All these issues dissapear as soon as I reflash the original tune to the PCM. Then everything is OK again. I am now running the standard tune with 20% throttle boost; Although better than stock I would like to use the Diablo tunes as intended..

Any help would be appreciated!


Return to Predator Dodge Gas