Board index Trinity Technical Discussion Trinity GM Gas Support for TCM disabled?

Support for TCM disabled?

Post any questions or comments about your Trinity for your GM car or gas truck here.

Moderators: mikel, 06MonteSS

Post Wed Apr 04, 2018 10:28 pm

Posts: 7
So I had to take my truck in fro some service work. As always I uninstalled the Trinity from the truck before dropping it off.
After I got it back I reinstalled my tune and all was well. Until I tried to view live date.
Every time I click it gives me an error message that reads "Support for "TCM" Disabled. Restore Original backup to enable support"

What the crap?

It has never done this before.

I did to the most recent update while I had it uninstalled. Is this the problem?
What do I do now?
It is not changing my shift points and such like it used to.

Thanks.

Post Thu Apr 05, 2018 9:32 am

Posts: 17258
Location: CT

yep... normal for trucks usually...

restore original backup stock tune to the truck..

then reinstall the preset canned tune, and this time around it will ask you to also select a TCM/tranny tune to install, and you can modify it, etc..
06MonteSS / DiabLew Tune
Image
2014 Camaro SS - 2SS, RS pkg., short-throw shifter, NPP perf. exhaust, BMR strut-tower brace, Cold Air Inductions cold air intake
www.diablewtune.com -- www.diablocustomtune.com -- www.diablocustomtunegm.com -- www.diablocustomtuning.net

Post Fri Apr 06, 2018 4:44 pm

Posts: 7
OK I'll try that.

It never asked me for the trans tune or tuned that module when I installed it the last time now that I think about it.

Post Wed Jun 13, 2018 12:07 am

Posts: 8
I have sort of a similar problem. Used my Trinity previously on my 2016 6.2 with 8 speed prior to having tcm support just to tune the engine. Worked fine with no issues. Restored to original when I brought it in to the dealer back in November. Tried to use one of the canned tunes last week for the engine and transmission now that there’s tcm support and get the message that my calibration isn’t supported. Have been working with a couple tech guys And was finally able to get the thing to backup and I sent the original files in. Got a new crom back yesterday to add to the device. Seemed like it was going to work at first and then it came up with the unsupported thing again and wanted me to backup and send in again. I would’ve thought this time now that I was able to get the original files it would’ve worked. Is it possible the crom file isn’t correct still?


Return to Trinity GM Gas