Board index inTune i-1000 Technical Discussion Auto Updater/PC related issues i2 just keeps on updating and screen says"please wait"

i2 just keeps on updating and screen says"please wait"

Post any issues or questions regarding the inTune auto updater application, or any PC related issues here.

Posts: 3
I've tried updating my i2, when I plug it in to my computer, it says no updates are available. Fine, so then the actual tuner just keeps updating, then it'll say update completed. Tap to reboot. Then it reboots, comes back on, and starts updating again. At the moment it's plugged in to my Mac, and the screen says " PLEASE WAIT" and it's been doing this for about 15 minutes....When I unplugged it, and plugged it into the OBD port in my truck, it did the same thing, just kept rolling through the updating and installing process. Once in a while it would stop, then it would prompt to reboot. I reboot, it restarts and keeps doing the same stalling/updating/writing process.....Is it F'ED?


Posts: 53925
Location: DiabloSport World Headquarters

open i2 drive and delete the file called group_update.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 1
I am experiencing the same thing. I deleted the group_update.itfg file on the device and it started the update process again. But when it was done updating, it had me select continue to reboot. Now it is stuck in the please wait screen again. What do I do?


Posts: 3
I am having the exact same issue. Please help


Posts: 3
I have been having the same issue.


Return to Auto Updater/PC related issues