Board index i2/i3 Technical discussion Ignition updater i2030 won't go to menu after update

i2030 won't go to menu after update

Post here with any questions regarding the use of the Ignition updater software for PC or Mac

Moderator: sohfast94

Post Sat Dec 29, 2018 6:57 pm

Posts: 7
I decided to dust off my i2030 and install the latest updates. I "unmarried" if from my truck just in case and then ran the Diablo updater. Somehow the process went wrong (or has changed) and now the Diablo updater is gone and I have an "Ignition" program installed on my computer and my i2030 won't go into any menus.

When I connect the i2030 to power (either OBD or USB) it does the following:

  • Splash screen.
  • Checking / Installing Updates.
  • A screen with a Diablo logo and a ":" centered near the top.
  • The back arrow and help icon are both greyed out.
  • Stays here forever and doesn't go to any menu.

The info.xml is attached. Not sure what to do next to get my Diablo working. Can anyone help?

info.xml


Edit: More information that might help. I don't remember everything I've tried but earlier it was stuck in a loop where the i2 drive kept attaching and detaching from Windows while the device said "Installer:Preparing". I was able to connect to the device and delete the .itf file that was in the root folder. That made it stop the loop but didn't get it to go back to the menus.
You do not have the required permissions to view the files attached to this post.

Post Thu Jan 03, 2019 11:15 am

Posts: 54860
Location: DiabloSport World Headquarters

Can you try updating it again to see if that helps?
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Thu Jan 03, 2019 2:28 pm

Posts: 17517
Location: CT

yes, the Ignition Updater is the new program to update the intune... it's been that way for a long while now...

Get the latest version of it here: https://www.diablosport.com/downloads/ -- Update Agent 1.0 (Formerly Ignition) (for PC)

get that installed on your pc and then run it to get your intune updated to all the latest updates..

if yours was still using the original updater app, then it's been a long while since you updated your intune, so it could take a while, as there have been a LOT of updates since way back then.
06MonteSS / DiabLew Tune
Image
2014 Camaro SS - 2SS, RS pkg., short-throw shifter, NPP perf. exhaust, BMR strut-tower brace, Cold Air Inductions cold air intake
www.diablewtune.com -- www.diablocustomtune.com -- www.diablocustomtunegm.com -- www.diablocustomtuning.net

Post Sat Jan 05, 2019 11:20 am

Posts: 7
Hi Mike, (and Monte),

I've gotten my i2030 into a slightly different state than before, but it still isn't working (or I'm not being patient enough).

Coming into today my device would power up (either via USB or OBD cable) and get stuck on a ":" screen.

I followed Monte's advice and reinstalled the Ignition Updater (with "Repair") and received the "Repair Successfully Completed" message and then I connected my device.

When I reached the "Account" screen where it asks for name and email address I had previously been doing nothing. The old Diablo updater didn't have a screen like this and I assumed it was an optional step, not needed for updating. This time however I entered my information. After I did that Ignition said my device needed updates and started downloading them. It reached a point where it claimed to be installing "Diablo Master r154 (13 files)".

My device then progressed to the point where it said "Installer:Preparing" but then appeared stuck. I let it sit in that state for about 15 minutes and reconnected it. During the reconnection I was able to see the i2 drive contains a 28 MB group update ".iftg" file.

I then left it at "Installer:Preparing" for 10+ hours and it didn't do anything, so eventually I unhooked it.

What should I try next?

Thanks!

Post Mon Jan 07, 2019 10:18 am

Posts: 54860
Location: DiabloSport World Headquarters

can you post the current info.xml file from the device?
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Tue Jan 08, 2019 8:19 am

Posts: 7
Somehow it is working now :D .

I hooked it up to power to pull the .xml you requested and noticed that instead of getting hung it started going through the install process. It completed the .itfg that was previously installed. I then run the updater again and it installed Diablo Master r155 (4 files). Looks like the device is functional now although I have no idea why it decided to install this time and hang the last several times.

One quirk - maybe this is normal - if I connect it and run the updater it always says I need an update and redownloads r155 (1 file). After installing that it will say I'm up-to-date. However, if I run the updater again it will repeat that whole process (download and install r155). I can't get it to a state where I run the updater and it immediately says I'm up-to-date. Maybe that is normal?

I might hold off on tuning my truck until you tell me if things look good, but at least I'm functional again. Current .xml is attached for you also.
You do not have the required permissions to view the files attached to this post.

Post Tue Jan 08, 2019 10:32 am

Posts: 17517
Location: CT

yes, normal quirk/bug...
06MonteSS / DiabLew Tune
Image
2014 Camaro SS - 2SS, RS pkg., short-throw shifter, NPP perf. exhaust, BMR strut-tower brace, Cold Air Inductions cold air intake
www.diablewtune.com -- www.diablocustomtune.com -- www.diablocustomtunegm.com -- www.diablocustomtuning.net

Post Wed Jan 09, 2019 7:15 am

Posts: 7
Ok, thanks Mike and Monte, I'll go tune my truck again.

Not sure what happened here but I appreciate the guidance through it.


Return to Ignition updater