Board index Predator 2 Support Predator 2 for Chrysler/Dodge/Jeep/Ram Predator P2 (7302) recovery mode, vehicle unable to start

Predator P2 (7302) recovery mode, vehicle unable to start

Discuss Predator 2 for Chrysler vehicles

Moderator: sohfast94


Posts: 2
Just received my tuner (2014 Ram 1500 5.7L 8-spd auto) from Summit racing, and read over the manual. I've used a Predator in the past for my Silverado, so I was somewhat confident in what I was doing. I skipped updating because my laptop died a week ago, and just plugged the tuner in to the OBD port. I chose the 91 tune, and it backed up the stock settings (2 files). Then I customized the tune with raised top speed and increasing throttle response by 10%. It built the tune and then asked if it was ok to proceed. I pressed OK and off it went. I had to turn the ignition on and off several times (probably more than a dozen), and it eventually said OS MOD PROGRAMMING ERROR, then said it was in recovery mode, and only allows me an endless cycle of turning ignition on, clearing DTCs, and then asking me to turn ignition off. The scariest part is the truck saying to press the CLUTCH and press start to start... it's an automatic. I called tech support to find out they close at 5 PM EST and I'm in MST. After about 10 cycles, I reluctantly unplugged from the OBD port and brought the tuner inside. Installed the ignition software on my g/f's Mac, and plugged in the tuner via USB. It connects and displays my VIN, but says "recovery" on the left side of the window. If only I could get my vehicle back to stock I would be so happy I wouldn't think about the money it cost me... I now am unable to start my truck as it says to press the clutch to start, and it's an automatic transmission.

Very, very frustrated!


Posts: 4
Hey bud I had the same thing happen to me try unplugging your battery and plug it back on try putting a charger on your battery. Or even jumper cables I havent tried redoing mine since the weekend when the same thing happened to me And plug your tuner back in. I was able to upload my stock files back and my truck finally fired up.


Posts: 55874
Location: DiabloSport World Headquarters

jimtiner82 wrote:
Just received my tuner (2014 Ram 1500 5.7L 8-spd auto) from Summit racing, and read over the manual. I've used a Predator in the past for my Silverado, so I was somewhat confident in what I was doing. I skipped updating because my laptop died a week ago, and just plugged the tuner in to the OBD port. I chose the 91 tune, and it backed up the stock settings (2 files). Then I customized the tune with raised top speed and increasing throttle response by 10%. It built the tune and then asked if it was ok to proceed. I pressed OK and off it went. I had to turn the ignition on and off several times (probably more than a dozen), and it eventually said OS MOD PROGRAMMING ERROR, then said it was in recovery mode, and only allows me an endless cycle of turning ignition on, clearing DTCs, and then asking me to turn ignition off. The scariest part is the truck saying to press the CLUTCH and press start to start... it's an automatic. I called tech support to find out they close at 5 PM EST and I'm in MST. After about 10 cycles, I reluctantly unplugged from the OBD port and brought the tuner inside. Installed the ignition software on my g/f's Mac, and plugged in the tuner via USB. It connects and displays my VIN, but says "recovery" on the left side of the window. If only I could get my vehicle back to stock I would be so happy I wouldn't think about the money it cost me... I now am unable to start my truck as it says to press the clutch to start, and it's an automatic transmission.

Very, very frustrated!
please give us a call with the device powered up in the truck asap, 561-908-0040 x4


Thanks
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 1
I have the Predator P2 for my 06 300c 5.7. I went to install the factory file so I can update the p2 and everything went through and finished but my car will not start. Tried calling and e-mailing no anwsers any help would be greatly appreciated I also could not find for the life of me how to start a new forum sorry.


Posts: 55874
Location: DiabloSport World Headquarters

markleydavidjr wrote:
I have the Predator P2 for my 06 300c 5.7. I went to install the factory file so I can update the p2 and everything went through and finished but my car will not start. Tried calling and e-mailing no anwsers any help would be greatly appreciated I also could not find for the life of me how to start a new forum sorry.

please call in now, we are open.

561-908-0040 x4
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 2
UPDATE: DiabloSport service tech (Rick) was excellent to deal with over the phone, and believed that my voltage dropped below 13V while installing the tune. They recommend (although I did not see it written anywhere) to have the battery on a charger or on booster cables to another vehicle while tuning. As the tuner was now in recovery mode and the PCM had no programming, the tuner would need to be updated and the PCM force flashed with the stock settings. His experience was that getting a tow to a dealer and paying them an hourly rate more often than not ends on them telling you the PCM is fried and wanting you to purchase a new one. I opted to remove the PCM myself (3 bolts and 2 stubborn electrical connections), and send the PCM and tuner to PowerTeq in Orlando, FL. The PCM & tuner we're shipped back out to me the same day it arrived with them and once I received them, I installed the PCM and pressed the ignition to run (still said to press clutch to start), and then hit it again to turn it off. Pressed it again, and it was back to "Press Brake + Start"! I happily started it up and everything appeared normal.

I was a bit nervous to attempt tuning again, but put the truck on cables with the minivan running, and was keeping a steady 14.2V. The tune installed perfectly fine and I'm very happy with the results!

Rick was very friendly and helpful, and answered any emails promptly.


Return to Predator 2 for Chrysler/Dodge/Jeep/Ram