Board index Trinity 2 T2 for Dodge/Chrysler/Jeep/Ram Reset to factory bricked my car (car wont start)

Reset to factory bricked my car (car wont start)

This area of the forum is for discussions relating to the T2 monitor/tuner on Chrysler vehicles.

Moderator: sohfast94


Posts: 2
I tried to reset my car back to factory using the T2 and the device had an error - ever since then my car flashes a red security light and wont start. I've tried to use diablo t2 to reset codes but it requires me to place my vehicle in run, which im guessing since its in security mode doesn't work for what it needs because when i place it in run (even though it wont start) it just keeps saying "place to vehicle in Run". All the lights and everything comes on but it just wont start. Im thing it corrupted the files in a mid-tune (since the T2 error-ed out in mid-tune)and that's why my 2018 dodge challenger R/T wont start and is in security mode or whatever (red light flashing). Please HELP!


Posts: 56087
Location: DiabloSport World Headquarters

bypass harness installed?
If it wont recover please give us a call in the morning so we can try to get it going.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 2
Diablosport was excellent in helping me with this issue. I called them on Monday, went thru a few diagnostic tips that didnt work and ended up sending them my pcm - got it back today and everything works again - the way you support your clients in need is awesome and a testimony to you dedication to your product. Thanks again for all the awesome service, you guys are great and so is your support team!!!


Posts: 56087
Location: DiabloSport World Headquarters

glad we could help.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to T2 for Dodge/Chrysler/Jeep/Ram