Board index Predator 2 Support Predator 2 for Chrysler/Dodge/Jeep/Ram P2 Platinum serious problem after successful tune install

P2 Platinum serious problem after successful tune install

Discuss Predator 2 for Chrysler vehicles

Moderator: sohfast94


Posts: 2
I bought the Predator P2 Platinum for my 04 5.7 ram 1500, updated the tuner, installed the 87 octane tune successfully, now my truck won't start. After the tune installed it cleared DTCs, and after being told everything was successful I unplugged the tuner and turned the ignition on. Heard everything power up but now it's like something is trying to power on but can't. I plugged the tuner back up to my truck in hopes of just going back to stock and it told me it could not recognize my pcm... But it gets a lot better..... I took my tuner back inside to my computer to check if I just needed and update again. No I did not. Took it back out to my truck, plugged it in and it asked me if it was the same vehicle the tuner was last used on, I clicked yes, it then told me it could not ID my vehicle and proceeded to reset itself. Since then I've just gotten the "cannot ID vehicle" message. My obd2 scanner will not communicate with it either. My battery is not dead, when I open my door my odometer shows on my dash, insert the key and the door chimes sound, turn ignition on, my radio comes on, dash lights illuminate, but no start, not even a turn over. Just the sound of something that sounds like it's stuck in a loop. Please help me out, I love this truck too much.


Posts: 2
If needed I can put up a video of the sound I mentioned..


Posts: 55471
Location: DiabloSport World Headquarters

If you havent already please give us a call so we can get it recovered.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to Predator 2 for Chrysler/Dodge/Jeep/Ram

cron