Board index General Technical Support General Support Predator 2 problems

Predator 2 problems

General Tech Support Questions

Moderators: mikel, 06MonteSS

Post Wed Oct 02, 2019 12:18 pm

Posts: 5
I have predator p2 u7202. It worked fine before I did an update to r69. Now my tuner doesn’t work, the update didn’t update correctly.

I removed the tune from my now parked for the season vehicle (2016 Silverado 5.3) then did an update to the tuner which I thought went smoothly. I then tried to tune my winter vehicle (2007 Tahoe 5.3) and noticed right away that the tuner wasn’t working the same ... at the tune screen when I hit ok it starts reading my truck right away with no tune select options. When it does it’s thing it says database error, update device and reboots. I later check the device info and it says status upload failed and vehicle info shows the vin from my other truck. On the ignition update program it shows status: upload failed and my silverados vin tune level: 0 installing: r247 (0 files)

I reconnected to my Silverado to see what it would do and it does the same thing as my Tahoe. When I hit tune it starts reading the vehicle without the tune select screen and when done says database error, update to tuner required. Checking vehicle info now shows 2 vehicle OS numbers and says it’s on a stock tune.

I need help to first fix the tuner so it can be properly updated with the fixed database. Then I need to see if my Silverado was actually reverted back to stock

Thanks

Post Wed Oct 02, 2019 12:45 pm

Posts: 55388
Location: DiabloSport World Headquarters

Please provide the serial number off the device so we can look into this.
Stars with 20X, 9 digits.


Thanks
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Wed Oct 02, 2019 1:40 pm

Posts: 5
201296452

Thank you very much, past 2 days have been very stressful.

Post Wed Oct 02, 2019 3:30 pm

Posts: 55388
Location: DiabloSport World Headquarters

please connect to a pc and update twice in a row with the update agent software then it should work as expected.


Thanks
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Wed Oct 02, 2019 3:53 pm

Posts: 5
Thank you, I will try tonight.

Post Wed Oct 02, 2019 6:38 pm

Posts: 5
Hi, I did as you said. the first update loaded which was a reset file. After that, I restarted the ignition program and the VIN lock: upload failed was still there with my Silverado's VIN. I proceeded to download and install the next update which was 514 files successfully. I restarted ignition again just to check status's and if there were more updates and the VIN lock: upload failed was still there with my Silverado's VIN. It said there was another update for 514 files again so I downloaded and installed that successfully too. I restarted ignition and a different update was available which is the same one from 2 days ago that caused this mess ... that installed successfully. I check again and again with installs of the same last update. every time I check with ignition it tells me there is an update ... it's always the same.

Is there a way to do a clean wipe and factory reset?
Shouldn't I delete the old files on the tuner before starting the updates?

Post Thu Oct 03, 2019 11:18 am

Posts: 55388
Location: DiabloSport World Headquarters

Its just reloading the file we locked it to, it should be good to go in the vehicle now.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Thu Oct 03, 2019 12:19 pm

Posts: 5
I just tried it in my Tahoe and all works again. Thanks so much. :)

Post Thu Oct 03, 2019 12:27 pm

Posts: 55388
Location: DiabloSport World Headquarters

good deal, enjoy.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to General Support