Board index Trinity Technical Discussion General Trinity This might help: Trinity blank screen after update

This might help: Trinity blank screen after update

General Trinity Support

Moderator: mikel


Posts: 29
Alright guys, I was (CMR) tuning on a 06 charger the other day and decided to update Trinity after having some weird idle issues.

Im not sure if i got a corrupt download or just selected the wrong (incremental update) crom to flash but as soon as it loaded the update and went through the car selection screen it rebooted to a blank screen. I waited about 15 minutes and pulled power (it was plugged into the obd2 port on the car on my dyno and the usb port while the car had good voltage btw) and subsequent power up attempts were met with the same blank screen every time. The status led's would light up slowly then the screen would flash white then go black and do nothing.

Long story short I called Diablo and they gave me a possible fix that worked! I searched here before calling and didnt find much so I figured i'd post it here in case it helps someone.

To fix this I re-downloaded the correct CROM to a new directory (diablo, you guys should really consider posting the md5 hash or some CRC check to verify downloads with (unless dsdownloader already has a CRC check)).

Once downloaded i took the trinity that was unplugged and powered off at this point, I then held down the "left" arrow key while pluging in USB that was connected to my powered up laptop.

I continued to hold the left key until I was delightfully met with the choose vehicle screen again!

At this point I initiated the update with the base (non incremental) update file (1v11 iirc) and started the process over.

20 minutes or so later I was left with a now fully updated (1v11b) trinity that I went on to tune the car with!

So yea, if you're stuck with a dead trinity from a bad update you can try this before going the RMA route, though Diablo may want to chime in on the specifics of how or if this will affect waranty.

Anyway, enjoy discuss etc....

Cliff notes:
-Dead trinity with blank screen on boot?
-Hold down "left" arrow while powering up off of USB
-Continue holding until you're hopefully met with choose vehicle screen.
-reload new freshly downloaded verified correct CROM update


Posts: 55110
Location: DiabloSport World Headquarters

glad this worked.
Reloading 1r11 mega crom is the fix, sorry you had to run through this :)
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 2
So glad you had this posted up. I just received my Trinity yesterday and had the blank screen issue after registering and doing the update for 2014 Dodge products. This process worked to fix my issue as well. I will add that the whole process took at least 3 hours and was WAY more frustrating than I expected it to be. But at least it is done.


Posts: 1
Good job, thanks for the post i didn't know what i was going to do next, but this worked great :)


Posts: 7
Thanks, I didnt needed to update again, jus rebooted holding the left key twice.


Posts: 2
I know that this is an old post but this just saved my weekend. I was seriously bummed out when I updated my Trinity and got this blank screen. Good lookin out, Brother! Thanks. :D

:lamer: Mikel I need some help. I am having this same issue and am not able to find the 1R11 mega Crom file.

mikel wrote:
glad this worked.
Reloading 1r11 mega crom is the fix, sorry you had to run through this :)


Posts: 55110
Location: DiabloSport World Headquarters

cant do that, that had to be from like 5 years ago....try the 1r13 mega.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Next

Return to General Trinity