Board index Trinity Technical Discussion General Trinity Freezing at "turn key to off"

Freezing at "turn key to off"

General Trinity Support

Moderator: mikel

Post Mon Apr 02, 2018 3:14 pm

Posts: 7
Email sent last night but writing here as well...

Tried to restore original tune last night, multiple times. Went through writing to 100% and said to turn key to off. Then it stayed there, frozen, when I turned the key off.

Car unresponsive until I unplugged the tuner. Started car, drove around, tried again with same result. Both times it says last tune written is 91 oct tune, however it's not actually on there, I can feel the MDS kicking in.

Trinity T1000, 2014 Challenger R/T, 5.7L ... I used the key not the push button, battery was brand new/charged, stereo off, lights unplugged, doors closed, windows up. I've used the tuner multiple times.

There is a thin blue line running vertically down the left side of the screen, but it's been there through multiple successful tunes.

Also both times it threw codes/engine light on dash, but it does that every single time I've used it (both canned tune and restoring stock), I was able to successfully erase the codes last night both times.

Post Thu Apr 05, 2018 1:42 am

Posts: 7
Still waiting for a response, either here or to the email I sent. I need to know what's wrong with my tuner.

Thanks.

Post Thu Apr 05, 2018 11:04 am

Posts: 55155
Location: DiabloSport World Headquarters

try a battery reset then try the restore again please.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Sat Apr 07, 2018 11:09 pm

Posts: 7
Unhooked battery, discharged, let it sit, hooked it back up and tried to reload it. Did the same thing, froze at turn key off.

What should I do now?

Thank you.

Also I tried to go to quick adjust to try and turn MDS back off in the mean time, and I don't see the option anywhere, just axle ratio/transmission/throttle is in the list. Is that normal? I've never done quick adjust, I've always just turned MDS off while loading the tune.

Post Mon Apr 09, 2018 8:23 am

Posts: 55155
Location: DiabloSport World Headquarters

MDS is not a quick adjust, its in the modify param menu.
does it allow you to restore?
are you adjusting something in quick adjust each time?
if so try with no changes.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST

Post Mon Apr 09, 2018 7:02 pm

Posts: 7
mikel wrote:
MDS is not a quick adjust, its in the modify param menu.
does it allow you to restore?
are you adjusting something in quick adjust each time?
if so try with no changes.

No, it won't let me restore, that's what I was originally trying to do so I could go to the dealership. I only tired to turn mds back off to see if it would let me. I didn't adjust anything in quick adjust.

Basically when I try to restore stock tune it freezes at turn key off after "writing" for about 15 mins. It goes all the way to 100%, tells me to turn key off which I do immediately and it stays on that screen.

Post Wed Apr 11, 2018 8:25 am

Posts: 55155
Location: DiabloSport World Headquarters

give us a call and we can reset the device and start over.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to General Trinity