Board index (Legacy) Predator Technical Discussion Predator Dodge Diesel Original backup failing

Original backup failing

Predator support for Dodge diesel vehicles

Moderator: mikel

Post Sat Mar 07, 2015 1:16 pm

Posts: 2
2003 Dodge 3500 Non-HO Cummins Automatic 4x4
Predator U7130

This is an older Predator that I have had since 04 (?) on two different vehicles, never updated the software.

I recently replaced my injectors and crossover tubes, after which I was having some problems. While trying to diagnose the problems, I reinstalled the original backup from my Predator. Everything went fine with that and it turned out to be a couple of bad injectors. I replaced the injectors and tested the truck-seemed to be good to go, so I went to put my performance tune back in...that's when I ran into a problem.

The write failed at about 52%, then required me to reinstall my original tune which I then tried to do. It also failed about 52%, saying to disconnect the batteries for 30 seconds and try again. Same thing twice after that, even after disconnecting the batteries. The screen says something like original backup failed (-1).

The vehicle is now non-op and of course, parked in front of the garage and my backup vehicle! Tried to call you guys but you're closed. Now what??

Thank you for any help you can give me!

Post Sat Mar 07, 2015 7:20 pm

Posts: 2
Well, I don't know what the heck that was all about, but now that it's a bit warmer outside I tried it again and it worked. Is it possible that the cold weather was causing it to fail writing to the computer? It wasn't even really cold, 20 degrees or so.

Crisis averted. I am updating the software on my Predator right now. (fingers crossed)

Post Mon Mar 09, 2015 2:18 pm

Posts: 55110
Location: DiabloSport World Headquarters

could have been weather or voltage related....
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to Predator Dodge Diesel