Board index (Legacy) Predator Technical Discussion Predator Ford Diesel predator 7.3 not recognizing the ignition - help

predator 7.3 not recognizing the ignition - help

Predator support for Ford diesel vehicles

Moderator: mikel


Posts: 3
I have a predator 7.3 and have used it for years with only one previous issue with an invalid license issue which was resolved by a Diablo sport technician back in 2008. I have backup the orginal tune and reloaded the 60 hp tune altered with a firm shift many times over the years. I mostly leave the 60 hp tune in but ocassionally do a restore when I need to put the vehicle a shop especially the dealer. When I recently went to backup the original tune the tuner did its normal cycle saying:
- booting ford 7.3
- the main screen appears
- I select performance tune
- I select restore backup
- it says turn the ignition on, no errors or message at this point
- it tells me to turn off the ignition
- it then says to turn on ignition and the second time it says the ignition is not on or I have a chip.

this happens if I attempt to do a back up or reload the 60 hp tune.

Does anyone have any idea as to what could be causing the tuner to not recognize the ignition? I am wondering if there is something wrong with the tuner or if something is wrong with my truck but everything on the truck is functioning including the key and anti-theft system and it doesn't matter what key I use as I have tried several keys and have also disconnected the battery a couple of times thinking that may help.

I appreciate any response!


Posts: 54982
Location: DiabloSport World Headquarters

sounds like a FEPS issue, please send the tool in for a fix.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Return to Predator Ford Diesel