Dataviewer Not Displaying Analog Input

Questions and comments regarding the DiabloSport data logging tools.

Moderator: mikel

06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

So I finally narrowed it down, I’ve been chasing an issue datalogging a 0-5v analog Input I wired up for a wideband AFR, and it’s working just fine. Even check the 2.5mm jack with a DVOM, all ok. Something seems to be up with the dataviewer software, any chance we can expect a patch anytime soon, I was made aware of this issue when I called tech support but I couldn’t get an ETA on an update that will fix the issue.
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Dataviewer Not Displaying Analog Input

Post by mikel »

its a bug, we are working on a solution, sorry for the delay.
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

mikel wrote:its a bug, we are working on a solution, sorry for the delay.
Thanks for the reply, appreciate it
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

mikel wrote:its a bug, we are working on a solution, sorry for the delay.
has this issue been rectified yet? i havent seen an Dataviewer update yet. i do all my tuning via email and im at the point where im switching fuels and im literally waiting on this.
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Dataviewer Not Displaying Analog Input

Post by mikel »

do you have a current log I can look at that has the analog in it?
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

mikel wrote:do you have a current log I can look at that has the analog in it?
I don’t have a current log since updating the tool, only from trying last time. I can post that if you wish
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

This should be it.
Attachments
07082_00.log
(326.54 KiB) Downloaded 237 times
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

mikel wrote:do you have a current log I can look at that has the analog in it?
This was from today
Attachments
07082_01.log
(35.35 KiB) Downloaded 236 times
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Dataviewer Not Displaying Analog Input

Post by mikel »

It is displaying properly in DV 3.4.3.1 which is current.
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

mikel wrote:It is displaying properly in DV 3.4.3.1 which is current.
Am I doing something wrong? I see it displaying something but it doesn’t change throughout the log, it varies barely any.
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Dataviewer Not Displaying Analog Input

Post by mikel »

thats gotta be a scaling issue if the values are not correct.
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
06SRT300
Posts: 37
Joined: Sun Apr 30, 2017 2:01 pm

Re: Dataviewer Not Displaying Analog Input

Post by 06SRT300 »

I’ve tried it scaled 2 different ways, 10.0/20.0 and 10.00/20.00. PLX says those are the values to be used, and I’d agree that the scaling is off but looking at the log on my laptop the number barely changes, it’s scaling in the 10.XX area and that’s it, coasting, cruising, or full throttle.
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Dataviewer Not Displaying Analog Input

Post by mikel »

then its not getting the correct signal.
You can monitor voltage and it should be 0-5V, if its barely changing there is something missing in the signal.
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
Hurycne
Posts: 2
Joined: Sun Nov 22, 2015 1:15 am

Re: Dataviewer Not Displaying Analog Input

Post by Hurycne »

On version 3.4.4.21 external inputs are not registering. When I use the same log on a previous version of the Dataviewer it shows my external AFR input. Anyone else running into this?
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Dataviewer Not Displaying Analog Input

Post by mikel »

Yes, we have a fix coming, sorry for the delay.
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
Post Reply