p0430 AFTER The tune was installed

Post here with any questions regarding the use of the i2 on supported Chevrolet, GMC, Cadillac, Buick, and Pontiac applications.

Moderator: sohfast94

Post Reply
bhamer
Posts: 3
Joined: Mon Nov 23, 2020 4:42 pm

p0430 AFTER The tune was installed

Post by bhamer »

Good day all,

I am wondering if anyone else has experienced this problem. I recently had to replace the y-pipe on my 15 Silverado due to a left bank failure. I put in a new y-pipe and 4 O2s just to be safe(truck has about 135k on it). Within a week the cel came on with a P0430. I cleared it, and then within about 100 miles it came on again. I have reset the CEL 4 times now, and every time it comes back.

Well I had to make a little road trip 2 weekends ago , so I figured I would reset the PCM to factory. and the CEL has not come back on at all.

The only things changed on the "tune" was, I deactivated the DOD/AFM, firmed up the trans shifting, and changed the tire size.

There are no leaks that I can tell from the exhaust, and the truck is running normally.

Any Ideas?
User avatar
mikel
Posts: 56623
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: p0430 AFTER The tune was installed

Post by mikel »

Try reloading the tune and see what you get?
To me it sounds like they were aftermarket converters that flow more than stock and may be leading to a false P0430 code.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
bhamer
Posts: 3
Joined: Mon Nov 23, 2020 4:42 pm

Re: p0430 AFTER The tune was installed

Post by bhamer »

Thanks Mikel
You are correct, they were an aftermarket replacement. I did get them replaced under their warranty, due to the CEL coming back on again.
If that is the case, what do you guys charge for a custom tune to turn the O2's off?
User avatar
mikel
Posts: 56623
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: p0430 AFTER The tune was installed

Post by mikel »

Turning off rear O2s is a bad word, we don't do it :)
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
bhamer
Posts: 3
Joined: Mon Nov 23, 2020 4:42 pm

Re: p0430 AFTER The tune was installed

Post by bhamer »

:lol:

Got ya Mikel.

Who would I contact for a custom tune for so performance upgrades?
Post Reply