Help needed.

Post here with any questions regarding the use of the i2 on supported Chevrolet, GMC, Cadillac, Buick, and Pontiac applications.

Moderator: sohfast94

Post Reply
Rmartin05
Posts: 4
Joined: Sat Mar 07, 2020 2:55 pm

Help needed.

Post by Rmartin05 »

I have a 2004 chevy avalanche z66 with the ls1 gen3 5.3L. Cold air intake and race exhaust no muffle with x pipe. Was throwing p0101 and p0300 mass air flow sensor and random misfire. Replaced the maf sensor with a jet one and put on new msd master blast with new wires and e3 plugs. Still ran rough found out cats was clogged so had removed and adjusted the cot parameter runs better but still stumbles around 3000 rpm.
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

Re: Help needed.

Post by mikel »

the JET MAF can/will lead to all sorts of issues from what I have seen, probably better off with a stock replacement.
Do you still get a P0300?
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
User avatar
06MonteSS
Posts: 17794
Joined: Tue Jan 23, 2007 11:33 am
Location: CT
Contact:

Re: Help needed.

Post by 06MonteSS »

Do NOT get an aftermarket MAF sensor... bad bad bad.. I wouldn't put anything Jet on a tricycle.... Aftermarket MAF sensors do not report true, correct information to the pcm... aftermarket MAF sensor calibrations fool the pcm into thinking the engine is running leaner than it really is, so when trying to tune it and adjust the fueling correctly, it will never really be right/correct, because that aftermarket MAF sensor is not reporting true/accurate info to begin with... They usually cause idle and driveability issues, and plus, the stock GM MAF sensors are good for 600+ hp anyway, so there is no reason at all to change it... so get a new stock GM/AC Delco/Delphi MAF sensor that is the correct part number for that truck...

Also, I have seen MSD stuff cause misfires time and time again...

And the same with those gimmick E3 plugs... worst ever!!

You want to use stock coils, and AC Delco or NGK plugs and plug wires, hands down!!! That will cure your issues...
06MonteSS / DiabLew Tune
Image
2014 Camaro SS - 2SS, RS pkg., short-throw shifter, NPP perf. exhaust, BMR strut-tower brace, Cold Air Inductions cold air intake
www.diablewtune.com -- www.diablocustomtune.com -- www.diablocustomtunegm.com -- www.diablocustomtuning.net
Rmartin05
Posts: 4
Joined: Sat Mar 07, 2020 2:55 pm

Re: Help needed.

Post by Rmartin05 »

Well since replacing mag with the jet and putting msd coils and cutting the cats off found out they where clogged. Only codes her now is from o2s and missing cats. But she runs good till 3000 rpm then stumbles real good but once she gets past the stumble she takes off like a rocket
User avatar
06MonteSS
Posts: 17794
Joined: Tue Jan 23, 2007 11:33 am
Location: CT
Contact:

Re: Help needed.

Post by 06MonteSS »

well... good luck with that, until you do what I mentioned... enjoy....
06MonteSS / DiabLew Tune
Image
2014 Camaro SS - 2SS, RS pkg., short-throw shifter, NPP perf. exhaust, BMR strut-tower brace, Cold Air Inductions cold air intake
www.diablewtune.com -- www.diablocustomtune.com -- www.diablocustomtunegm.com -- www.diablocustomtuning.net
Post Reply