Board index i2/i3 Technical discussion Ignition updater i2 updater being replaced with Ignition software

i2 updater being replaced with Ignition software

Post here with any questions regarding the use of the Ignition updater software for PC or Mac

Moderator: sohfast94


Posts: 55463
Location: DiabloSport World Headquarters

Moving forward, the existing i2 updater application that lives on the i2 will be replaced with our Ignition software.
You'll update the i2 then next time you go to update you'll see the ignition installer in the i2 drive/updater folder. Run that and install the software, then create an account and you'll use that to update moving forward.

Please let us know if you have any questions.

Thanks
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 3
Just updated it with the new ignition software. It says the updater is missing under the "MORE" button. I can't open the settings or the account information on the Ignition software. Whatever it says under the settings or account icons at the top disappears before I can click on it. Also there is no option to turn on wifi that I can see?


Posts: 55463
Location: DiabloSport World Headquarters

once it connects to the device click the little gear icon at top right and select register for wifi.
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 3
When I click on the gear there is a drop down menu but that menu disappears almost instantly. I tried uninstalling it and reinstalling it, nothing changed.


Posts: 55463
Location: DiabloSport World Headquarters

can you post the info.xml file from the i2 drive here?
Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST


Posts: 14
Location: West Monroe, La
I believe I'm having the same issues as well, here is my info.xml
You do not have the required permissions to view the files attached to this post.


Posts: 159
Same here. Just happened to me. info.xml attached
You do not have the required permissions to view the files attached to this post.


Posts: 159
Got it to work. Simply HARD reboot (not quick, hibernate, or sleep) your PC.

Seems like it was a driver conflict. When you hookup the I@ for the first time, the pre-installed driver is loaded. Then we run the updater utility which downloads ignition software, which is then loaded. Now you have two drivers loaded, assuming. I never opened DOS cmd and ran fltmc to check loaded drivers. However, reboot worked.

Also, the disappearing act ONLY happens to me when the screen is not FULLY expanded.

I was also prompted to register my device first, which I did.


Posts: 3
If I maximize the window I can get into the setting but I still can't enable the wifi. It takes me to the registration window which I already registered for. When I go to the wifi configuration on my I2 it's still grayed out.


Posts: 1
Same boat here. Cannot activate WI-FI, Keeps going to registration screen, then says that it has already been submitted.


Posts: 6
I'm having the same problem. Using Ignition and go through the update process on Win7 machine get to "installing updates, Your update is now being installed, please follow the instructions displayed on your device."
Then I get the following: "If the screen below is displayed, please disconnect and then reconnect your device."
BUT I never get that screen. My I2 continues to show the first screen with the only item active is Settings. Wifi configuration on next screen is grayed out.
Also when I connect to my Mustang and select Tune it goes into a "please wait" loop. I've done this multiple times and nothing works.
And I've shut down and rebooted my Win7 laptop.
Any update?


Posts: 9
Doesn´t work. Reboot PC, cant connect device to login. same problems than above post´s.

Update works now, thanks. Now i wait for Wifi.
You do not have the required permissions to view the files attached to this post.
Last edited by Bullwei on Mon Apr 17, 2017 3:57 am, edited 1 time in total.


Posts: 1
Installed the Ignition software and updated the tuner and now I am getting a "vehicle is not supported..." message. I flashed my PCM at the dealer and still wont work.
You do not have the required permissions to view the files attached to this post.


Posts: 23
Location: Indiana
I have an i2030 for GM, and to get Ignition to recognize my tuner I had to do a complete shut down-
restart of my pc, not just a restart. I use windows 10. Everything almost works right.

Plug your tuner into the pc, let it boot up, then open Ignition. Ignition should find your tuner, or
at least it did for mine.

Ignition comes on and reads "checking for updates", the little windows circle goes
round and round, and then Ignition ALWAYS tells me I have an update. It ALWAYS tells me
I have 4 files to download and install, but I think it's the same ones I just done? I did this
3 or 4 times thinking Ignition would finally tell me I'm up to date....but no.

Why won't Ignition tell me that my tuner is already up to date after the little windows circle stops
going round and round? "Checking for updates" Something like "Your tuner is up to date".

Apparently Ignition doesn't know I just downloaded and installed the latest update, 4 times...unless I didn't?
Maybe I'm doing something wrong.

Note: For those of you who can't get the wifi to work, you must order a kit that DiabloSport will
send to you free of charge.

Note to Diablo guys: You have a small typo error. Where it reads "Your update is now being installed,
please follow the instructions displayed on your device."

Mine reads: "Your update is now being installed, please follow the
instructions diplayed on your device."

The "s" is missing.

Alright...whos in charge of the proof reading :D


Posts: 3
info.xml

also having issues tunes file is empty (MAC) Ford F150
You do not have the required permissions to view the files attached to this post.


Return to Ignition updater