Board index Trinity 2 T2 for Dodge/Chrysler/Jeep/Ram After Update Custom Tunes won't load... At my Wits End!

After Update Custom Tunes won't load... At my Wits End!

This area of the forum is for discussions relating to the T2 monitor/tuner on Chrysler vehicles.

Moderator: sohfast94

Posts: 4
Had a pretty horrible experience today with my T2, which has been nothing but a headache every since I purchased it. My previous issues included MDS disabling Building Tune, Glitchy gauges, Unit of Measure not saving, and the list goes on... I have spent probably over 10 hours calling into tech support and trying different updates constantly to try and get simple functions working or UI glitches fixed. I'm at my wits end!

So here is my latest issue and the reason I am posting it on here is because tech support is closed for the weekend and I feel like throwing my T2 off of a 10 story building... For about 6 months I have researched all the mods I wanted to do to my Gen3 Hemi and collected all the required parts... I did the research to find a good local CMR Tuner and found a Chrysler Tech to do all the work with some of my help. I then a few days ago called into Tech Support and made sure I was on the latest update for my T2 as I wanted to make sure everything went smoothly and I wasn't going to waste any time or money....So for the past few days we ripped apart my engine and did almost every possible bolt on mod available... then I got a CMR Tuner to get me a base tune and we try and load it onto my T2 to find out it won't load the Custom Tune... we put it in the root folder of the T2 just like I have done 100 other times with custom backed up Canned Tunes... Nothing will load! So here I am paying for a licensed Tech and a CMR Tuner for my damn T2 not to even load the custom tune... All the mods took around 18 hours and the let down of not even being able to start my highly modded car because the update I have just recently received for my T2 is absolute GARBAGE. Can you imagine the let down and the wasted time and money to find out something that worked perfectly fine with custom tunes will no longer even load a custom tune! I'm so fed up with this product. Here Diablosport is supposed to be the leaders of automotive tuning but all I have experience is frustration and glitches since day one.

So the battle continues... here I paid a tech 18 hours labour and $500 for a CMR tuner to get absolutely nowhere... now I have to call tech support Monday morning to try some other T2 firmware or do some troubleshooting. This is getting ridiculous!

Posts: 4
So after hours and hours of trying different cables, computers, and tune files I still hadn't fixed the issue last night. So I tried again this morning and I deleted all my previous tunes, hit the device reset in the setting menu, waited for a reboot then copied my tune file over again it finally worked. I was able to copy and then flash my CMR Tune and start the car.

Now it was time to log all the data via Dataviewer. I opened Dataviewer, started my car, then connected the usb cable to my laptop to find that he T2 wouldn't connect. I had previously done this several times before I had updated all the T2, Diablosport Applications & Drivers on my laptop. I began troubleshooting by removing all the diablosport applications/drivers and the required windows drivers. I installed everything fresh and I still could not connect via Dataviewer. I then installed DS Downloader which I don't believe is even required for the T2 and it installed Microsoft Visual C++ 2013 v12 and presto Dataviewer connects finally.

Why the hell doesn't a required windows application not automatically install when Dataviewer is installed. I know it installs other versions of Visual C++ so why not v12? Again just another ridiculous bug in my nightmare of a time with the T2.

IMO there is something systematically wrong with the way Diablosport develops and tests their work. Whether it is not beta testing openly enough or just poor engineers I do not know but I doubt once I'd ever buy another Diablosport product again in my life. I still feel bad for all the people who had their TCMs bricked by the T2! Luckily I wasn't one of these people.


Posts: 56317
Location: DiabloSport World Headquarters

Im wondering if you uninstalled the C++ stuff when you did the previous uninstall?
Thats not a common issue with DV at all.

As for the custom tune loading, it sounds like there may have been something on the drive causing issues?
Again this is not something I see with any regularity, but I am really sorry to hear it happened to you.

Mike Litsch
Powerteq Customer Service Manager
Diablo Tech support by phone:
M-F 8:00 AM to 5:00 PM EST

Return to T2 for Dodge/Chrysler/Jeep/Ram