Board index Trinity 2 T2 for Dodge/Chrysler/Jeep/Ram Had a strange LTKR incident today

Had a strange LTKR incident today

This area of the forum is for discussions relating to the T2 monitor/tuner on Chrysler vehicles.

Moderator: sohfast94

Post Tue Sep 03, 2019 9:41 pm

Posts: 1
Hoping someone can give me an idea here...

I have a 2018 Pulley and 93 octane Tuned 18 Charger Hellcat. Had the tune and pulley since June with no issues. Watch my pids very closely and have alarms set for a lot of values. Never seen even 1 degree of long term or short knock. Today I did a quick 40-100 pull. Outside temp was about 78 degrees, IAT's around 105. The pull was FINE, all the way up to WOT as usua, no ST OR LT knock during it. When I let off the gas and started deceling I heard my pid alarm. I look up and its my LT KR. 2 degrees, then 3, then 4 and climbing. I instantly pull over and go to shut the car off. The most confusing part is while I was pulled over, completely stopped, the degrees were rising still, up to 14 degrees. I shut car down, then a minute later started it back up. Drove to work at 65 mph fine. Brought RPMS up to around 3500 to see if I got any knock, and there was zero.

Later after work, slowly kept bringing my rpms up higher and higher, till I eventually did 3 more WOT pulls, and there was ZERO knock. Logged those pulls and everything looks fine, even my timing.

The two most confusing parts here are 1. Getting LT KR without ever getting ST, and more importantly, the knock degrees raising while the rpms were dropping, all the way down to a dead stop.

My tuner suggested bad gas. But wouldn't I have gotten ST first, or as well if this was the case? Plus wouldn't it have happened later?

Return to T2 for Dodge/Chrysler/Jeep/Ram