May be a stupid question but?? Here goes!

Predator support for Ford diesel vehicles

Moderator: mikel

Post Reply
iwantmorepower
Posts: 102
Joined: Mon Feb 26, 2007 6:27 pm

May be a stupid question but?? Here goes!

Post by iwantmorepower »

I have an issue with my 2003 6L , when it is cold it starts rough and the first few miles feels like it is missing (ya I know there' s no plugs) but same feeling . When it it warm it does not seem to be as bad , when the truck warms up it has good power . My question is it an injector or could it be FICM?
User avatar
mikel
Posts: 56629
Joined: Tue Jan 16, 2007 1:17 pm
Location: DiabloSport World Headquarters
Contact:

RE: May be a stupid question but?? Here goes!

Post by mikel »

Sounds like an injecotr or possibly FICM issue, yes, assuming the fuel filer is clean.
I also recall my roommates truck doing this when his EGR would clog up...
Mike Litsch
Holley Technical Sales Manager
Diablo Tech support by phone:
561-908-0040x4
M-F 8:00 AM to 5:00 PM EST
User avatar
tuningss
Posts: 1007
Joined: Fri May 23, 2008 5:25 pm

RE: May be a stupid question but?? Here goes!

Post by tuningss »

Most likley a FICM. Hard start when cold as well?
Certified Advanced EFI Calibrators for Ford, GM and DCX/Jeep Vehicles.
http://www.tpctuning.com
iwantmorepower
Posts: 102
Joined: Mon Feb 26, 2007 6:27 pm

RE: May be a stupid question but?? Here goes!

Post by iwantmorepower »

Yes I usually have to try 2- 3 times to start it when cold. I am in northern Canada and it is extremely cold here right now. There is no tell tale white smoke to indicate an injector, So I am leaning to FICM issue but wanted another opinion.
Post Reply